[jira] [Commented] (APEXCORE-740) Setup plugins does not identify operator classes because they're loaded through different classloaders

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (APEXCORE-740) Setup plugins does not identify operator classes because they're loaded through different classloaders

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/APEXCORE-740?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16036583#comment-16036583 ]

ASF GitHub Bot commented on APEXCORE-740:
-----------------------------------------

GitHub user chinmaykolhatkar opened a pull request:

    https://github.com/apache/apex-core/pull/536

    APEXCORE-740 Create new classloader with parent instead of overriding the parent

    RCA given in the jira.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/chinmaykolhatkar/apex-core APEXCORE-740

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/apex-core/pull/536.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #536
   
----
commit 407688861c87d76405dfd481d0bd791bec0f612b
Author: Chinmay Kolhatkar <[hidden email]>
Date:   2017-06-05T06:09:00Z

    APEXCORE-740 Create new classloader with parent instead of overriding the parent

----


> Setup plugins does not identify operator classes because they're loaded through different classloaders
> ------------------------------------------------------------------------------------------------------
>
>                 Key: APEXCORE-740
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-740
>             Project: Apache Apex Core
>          Issue Type: Bug
>            Reporter: Chinmay Kolhatkar
>            Assignee: Chinmay Kolhatkar
>
> Apexcli loads setup plugin and operator classes with different thread context class loader. Because of this, the setup plugin does not understand the operator classes.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)