[jira] [Commented] (APEXCORE-809) Documentation does not build with current versions (8.11.x) of nodejs

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (APEXCORE-809) Documentation does not build with current versions (8.11.x) of nodejs

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/APEXCORE-809?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16447101#comment-16447101 ]

Thomas Weise commented on APEXCORE-809:
---------------------------------------

Since the user docs are generated with mkdocs I assume this refers to the web site build. The web suite generator basically has been broken for a long time because the nodejs based build with its "versioning" (which is really a moving target) does not allow for a repeatable process.

There are other shortcomings and there has been some discussion about moving to Jekyll. CC: [~ananth.g]

 

> Documentation does not build with current versions (8.11.x) of nodejs
> ---------------------------------------------------------------------
>
>                 Key: APEXCORE-809
>                 URL: https://issues.apache.org/jira/browse/APEXCORE-809
>             Project: Apache Apex Core
>          Issue Type: Improvement
>          Components: Website
>            Reporter: Pramod Immaneni
>            Priority: Major
>
> Documentation fails to build with currently available versions of nodejs. One has to go back to the older release 6.9.1 for the build to work. Error is with the contextify module, it is no longer used in newer version as it has been integrated into nodejs directly and is available in a different form.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)